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JavaPOS Driver

1. Manual Information

This manual provides information on the BIXOLON JavaPOS driver as well as on the
usage POS printer products offered by BIXOLON.

The following are terms contained in this manual.

- JDK: Sun Microsystems Java Development Kit

- JRE: Sun Microsystems Java Runtime Environment

- JavaPOS: Java Point of Sale

- JCL: JavaPOS Configuration Loader

[Reference Websites]

http://www.javapos.com : Java POS committee website

http://java.sun.com : Official Java website

http://www.bixolon.com : BIXOLON printers website

We at BIXOLON maintain ongoing efforts to enhance and upgrade the functions and
quality of all our products. In following, product specifications and/or user manual content
may be changed without prior notice.
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2. Usage Environment
2-1 Features
Using standard API functions, the POS System can be developed more quickly and easily,
and applications can be developed independently from the operating system.
2-2 Supported Operating Systems
- Windows XP (32/64bit)
- Windows Server 2003 (32/64bit)
- Windows Vista (32/64bit)

- Windows 7 (32/64bit)
- Windows 8 (32/64bit)

2-3 Supported Interface

POSPrinter
Model Serial USB Ethernet Bluetooth Wireless LAN

SRP-275 O O O X X
SRP-275ll @) @) O X X
SRP-330 @) @) @) X X
SRP-350 O O O X X
SRP-350ll O O O X X
SRP-350lIl @) @) @) X X
SRP-350plus O O O X X
SRP-350plusll @) @) @) X X
SRP-350plusll| O O O @) @)
SRP-3521lI O O O X X
SRP-352plus O O O X X
SRP-352plusll O O O X X
SRP-352pluslll @) @) @) O @)
SRP-F310 O O O X @)
SRP-F312 @) @) @) X @)
SPP-R200 O O X @) X
SPP-R200II @) @) @) O @)
SPP-R300 @) @) O @) @)
SPP-R400 @) O O @) @)

2-4 Java Environment

- JRE (Java Runtime Environment) Version 1.5 or higher
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3. Installation

The BIXOLON JavaPOS driver includes the JavaPOS Device Control, JavaPOS Device
Service, JCL, manual, sample program, etc.

3-1 Installation
1) JDK & JRE Installation
a) JDK Installation

Download the 1.5 or higher version of the JDK for Windows from
http://java.sun.com/javase/downloads/index.jsp

b) Run “jdk-XXX-windows-i586-X.exe” and install the JDK.
* The JRE is installed automatically during JDK installation and thus no
separate JRE installation is required.

c) Select Start -> Settings -> Control Panel -> System.

* System may not appear if using Windows XP. In such cases, click “Switch to
Classic View” at the top left of the Control Panel, and the System icon should
appear.

d) In the Advanced tab, click the “Environment Variables” button.
e) Add the following content in the path value of both the user environment variables and
the system environment variables.
To Be Added: <JDK installed folder>\bin
Ex.) C:\Program Files\Java\jdk1.6.0_01\bin
f) Select Start -> Programs -> Accessories -> Command Prompt.

g) Enter “java —version” in the command prompt window.

h) If the following appears, installation has been completed successfully.

s CHWINDOWSWsystem32Wemd. exe

C:WDocuments and SettingsWcools>java —version

java version "i.6.68_81"

Java(TM> SE Runtime Environment ¢huild 1.6.8_81-h#6>

Java HotSpot(TM> Client UM <(build 1.6.8_@1-bB6,. mixed mode,. sharingd

C:WDocuments and SettingsWcoolsl
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2) Java Communication API Installation
a) Double click “Comminstaller.exe”.

b) Check JRE(Java Runtime Environment) location.

| £:) Communication Files Installer =0 ol =

JRE Location :  |[o:\Program Files\Java\jdk1.6.0_21\jre

[ Install Communication Files I

* If “JRE Location” is wrong, you should change it to your location.

c) Click “install Communication Files” button
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3-2 Jpos Entry Setting

Double click “Run JCL_Loader.Bat”. The JposEntry Editor begins.

| %/ BIXOLON JposEntry Editor- [jposxml] [XML] E
File Edit Help
(n[s]Ble]e][aja u [&]9]
Jpos Entries : Standard Properties | Bus Properties | Vendor Properties
¢ (] Entries Creation Properties B
# G POSPrinter v Property Name Property Value
[} srP-350plusii fogicalName
D SRP-352plusll sernvicelnstanceFactoryClass
[ srP-330 senviceClass
D SPP-R2001I JavaPOS Properties
¢ %% CashDrawer :
[y sSRPCDW Property Name Property Value
iposVersion
||||deviceCategory
Vendor Properties | Eat |
Property Name Property Value
vendorName OK
:|l|lvendorURL
l Cancel |
Product Properties
Property Name Property Value
productName
productURL
productDescription |
I =
Messages
Top of FileLoaded current JposEntryRegistry with 7 entry(ies)
Saved file: jpos.xml with 5 entry(ies)

1) Creating a New File

Click the C icon, or select “New” from the “File” menu.

2) Adding a POS Printer

a) Click the C icon, or select “Add” from the “Edit” menu.

b) Select “POSPrinter” in “Device Category”.
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c) After selecting the printer to be added in “POS Device”, enter the “Logical name”.

New JposEntry Properties

Logical name: [SRP-350plusli |

Registry populator: |JCL XML Entries Populator | v |

Device Category: | POSPrinter : POS Device:

| ox || cancel |

* The default value can be used without problem as the Logical name.

d) “Click the “OK” button and click Printer.model.

File Edit Help
B0
Jpos Entries Standard Properties | Bus Properties | Vendor Properties
9 [ Entries “|l-Creation Prop
# @ POSPrinter ; Property Name Property Value
D “|||[logicalName SRP-350plusll
[ srRP-352plusil -||[lservicelnstanceFactoryClass com.bixolon jpos.senvices.create.Bixolon, icelnstanceFactory
[ srP-330 ||{|serviceClass com.bixolon.jpos.sevices.printers. BIXOLONPrinterService
™) sPp-r2001I ||-savaPos properti
9 %% CashDrawer 2 b N B =
[ sRPCDW 1lI- . roperty Name roperty Value
B posVersion 1.13.0
“||||deviceCategory POSPrinter
|| -vendor l Edit I
E Property Name Property Value
‘|||lvendorName BIXOLON
:I \vendorURL |hﬂp:llwww.bixolon‘com
] [ Cancel |
|| -Product Properties
H Property Name Property Value
:||[[productName |BIXOLON Service for JavaPOS(TM) Standard
|l{lproducturRL |nttp:/iwww.bixolon.com
:|||lproductDescription |BIXOLON Standard Printer Device Service
Messages
Top of FileLoaded current JposEntryRegistry with 7 entry(ies)
Saved file: jpos.xml with 5 entry(ies)

Rev. 3.02



3) Adding a CashDrawer

a) Click the G icon, or select “Add” from the “Edit” menu.

b) Select “CashDrawer” in “Device Category”.

JavaPOS Driver

c) Select the printer to be linked to the CashDrawer in “Linked POS Device”.

| %/ Add POS Device Entry for BIXOLON

o]

New JposEntry Properties

Logical name: |SRPCDW |

Registry populator: [JCL XML Entries Populator Iv]

Device Category: [CashDrawer | v | Linked POS Device: [SRP-350PLUSH | v | Line wiam: [ [ |

[ OK H Cancel I

* When using a USB port, communication is not possible if the “Linked POS

Device” has not been properly selected.

d) Click the “OK” button and click CashDrawer model.

| %) BIXOLON JposEntry Editor- [jpos.xmi] (XML] [E=REER
File Edit Help
EEEIEONCYEYEIRE T
Jpos Entries : Standard Properties r Bus Properties r Vendor Properties
| Entries Creation Properties 2
¢ @ POSPrinter Property Name Property Value
[ srP-350plusii logicalName SRPCDW
[ srP-352plusli senvicelnstanceFactoryClass com.bixolon. jpos.senices.create.BixolonJpos ServicelnstanceFactory
[ srP-330 seniceClass com.bixolon.jpos.senvices.cashdrawer. BIXOLONCashDrawer
D SPP-R2001I JavaPOS Properti
¢ % CashDrawer = N = Val
[ sRPCDW | . roperty Name roperty Value
liposVersion 1.12.0
deviceCategory CashDrawer
Vendor Properties [ Edit ]
Property Name Property Value
vendorName BIXOLON l OK
vendorURL http:/iwww.bixolon.com
l Cancel ‘
Product Properties:
| Property Name Property Value
productName BIXOLON Service for JavaPOS(TM) Standard
rproductURL http:/iwww.bixolon.com
ll)rodudDescription BIXOLON Standard CashDrawer Device Service |
|} X
Messages
Top of FileLoaded current JposEntryRegistry with 4 entry(ies)
Saved file: jpos.xml with 5 entry(ies)
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4) POS Printer Communication Setting

a) After selecting Printer Model, select the “Bus Properties” tab.

JavaPOS Driver

r al
|| BIXOLON JposEntry Editor- [jpos.xml] [XML] = | B
File Edit Help
EEEIC OIS
Jpos Entries 4| standard Properties | Bus Properties | Vendor Properties |
¢ [C] Entries | -Device Bus (C ivity) Properties
¢ & POSPrinter )
[) sRP-250plusli beviceBus[ ||
[} srRP-352plusli 737 Properios
[ srP-330
\ [y spp-R20011 portName
¢ %% CashDrawer
I [ srecOW baudRate |
dataBits
party [ ||
stopBits I:[j l 0K
Messages
Top of FileLoaded current JposEntryRegistry with 4 entry(ies)
Saved file: jpos.xml with 5 entry(ies)

b) After clicking the “Edit” button, select the communication port to be used in “Device

”
Bus”.
r al
|| BIXOLON JposEntry Editor- [jpos.xmli] [XML] E=RECE
File Edit Help
EIREICIONE YIS
Jpos Entries 4| standard Properties |  Bus Properties | Vendor Properties |
¢ [C] Entries “| -Device Bus (Ct ivity) Properties
¢ & POSPrinter )
[} srP-350plusii Davice Bus
[ srP-352plusil UsB
~R$232 Propertls <
[ srP-330 RS232
[} spP-r20011 portName |CO|Bluetooth
I ¢ % CashDrawer
I [ srPcOw
dataBits
party can
stopBits Ezl
towconr farvare < .
i
Messages
Top of FileLoaded current JposEntryRegistry with 4 entry(ies)
Saved file: jpos.xml with 5 entry(ies)
=

- When using the USB port, no special settings are required.

Rev. 3.02
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- When Using Serial (RS232) or Bluetooth

JavaPOS Driver

[ sRPCDW / baudRate

b‘ dataBits

pry
stopBits EE
flowControl

| 4] BIXOLON JposEntry Editor- [jpos.xmi] [XML] [E=REE
File Edit Help
BEIEIDONEIY R
Jpos Entries : ( Standard Properties I/ Bus Properties | Vendor Properties |
9 [J Entries | -Device Bus (Ct ivity) Properties
¢ & POSPrinter d
[ sRP-350plusli : Uence Bus |
[ srP-352plusi / “RS737 Properties
[ srP-330 i
[y sPP-R20011 .: portName |COM1
' ¢ %% CashDrawer :

Edit

Messages

Top of FileLoaded current JposEntryReqgistry with 4 entry(ies)
Saved file: jpos.xml with 5 entry(ies)

- When Using Ethernet or Wireless LAN

| BIXOLON JposEntry Editor- (jpos.xmi] [XML] e T

al=]ale[e) [a]s]a] (]9

Jpos Entries 4|(" standard Properties | Bus ies | Vendor Properties |
¢ (=] Entries “| -Device Bus (C ivity) Properties
¢ & POSPrinter E i
[ sRP-350plusii| || - Device Bus
[} srP-352plusil ; T >
il [ sreP-330 :
I [ sPp-R2001 B IPAddress
¢ % CashDrawer ki
[y sRPCDW j: port [9100 ] wifi
Edit
R
Messages

||| Top of FileLoaded current JposEntryRegistry with 5 entry(ies)
Saved file: jpos.xml with 5 entry(ies)

=l

* Each item of the Properties must be identical to the current print settings.
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c) Click the “OK” button to complete the setting process.

* With regard to the CashDrawer, communication settings must be identical with the
connected printer. The setting instructions are the same as those for the printer.

5) CashDrawer PIN Number and linkedPrinter Setting

a) After selecting CashDrawer, select the “Vendor Properties” tab.

r o ™y
| %] BIXOLON JposEntry Editor- (jpos.xmi] (XML] [E=NEER
File Edit Help
EIEEIEONEENEEE
Jpos Entries : Standard Properties | Bus Properties | Vendor Properties
| Entries rVendor Properties
¢ @# POSPrinter Property Name Property Value Property Type 1=
D SRP-350plusl closeStatusPhaser low String =
[y srP-352plusii = :
linkedModel SRP-350PLUSII String
[y srP-330
D SPP-R2001I linkedPrinter 7 String
I 9 %= CashDrawer offTime 248 String
DSRPCDW il onTime 25 String
pinNumber String
L OK
Cancel ‘
_ 1
Add
E ‘ Remove
Messages
Top of FileLoaded current JposEntryRegistry with 4 entry(ies)
Saved file: jpos.xml with 5 entry(ies)
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b) Set closeStatusPhaser and pinNumber to correspond with the CashDrawer in use.

= Y
|£| BIXOLON JposEntry Editor- [jpos.xml] [XML] E‘m
File Edit Help
B IO EIRESE
Jpos Entries :| Standard Properties | Bus Properties | Vendor Properties
| Eptries ;‘ ~Vendor Properties
¢ @ POSPrinter Property Name Property Value Property Type
D SRP-350plusit ‘||| closeStatusPhaser low String =
[y srP-352plusli A= -
2l linkedModel SRP-350PLUSII String
[y srP-330 :
D SPP-R200II : linkedPrinter 7 String
“ ¢ % CashDrawer || offTime 248 String
[ | 2
D SRPCDW “fl|onTime 25 String
“||| pinNumber String
OK
Cancel
_
Add
E | Remove
Messages

Top of FileLoaded current JposEntryRegistry with 4 entry(ies)
Saved file: jpos.xml with 5 entry(ies)

- closeStatusPhaser: Signal value of CashDrawer when closed (low or high)
- pinNumber: PIN number used to open the CashDrawer (2 or 5)

Rev. 3.02
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c) Set linkedModel and linkedPrinter to link the CashDrawer.

JavaPOS Driver

r » bl
| %] BIXOLON JposEntry Editor- [jpos.xmi] [XML] | E
File Edit Help
EEIEICONEE NS
Jpos Entries : [ Standard Properties | Bus Properties | Vendor Properties
| E’ptries “li-Vendor Properties
¢ &# POSPrinter Property Name Property Value Property Type
D SRP-350plusll ‘||| closeStatusPhaser low String =
[y srP-352plusli A= -
“lf linkedModel SRP-350PLUSII String
[y srP-330 :
[ sPP-R200II ; linkedPrinter String
“ @ % CashDrawer 2|l| offTime 248 String
D SRPCDW “fl|onTime 25 String
||l pinNumber 2 String
OK
Cancel ‘
_
Add
E | Remove
Messages
Top of FileLoaded current JposEntryRegistry with 4 entry(ies)
Saved file: jpos.xml with 5 entry(ies)

* To change the Linked POS Device, the value of “linkedPrinter” under
“Vendor Properties” can be modified.
- SRP-350plusll: 0x7
- SRP-352plusll: 0x8

d) Click the “OK” button to complete the setting process.
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6) JposEntry Saving

a) Click the

JavaPOS Driver

button, or select “Save” from the “File” menu.

b) Make sure to set the file name to “jpos.xml” and click the “Save” button.

-
| %) Save As...

ot

Save In: |[] BIXOLON JavaPOS$S

Bl
N}

oQ
oo

(] Library
3] Manual

D jpos.xml

3] Sample Source

File Name:

Files of Type:

jpos.xml

XML entries (*.xml)

Save

Cancel

Rev. 3.02
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3-3 Test Program
Double click “TestProgram_Loader.Bat”. The JavaPOS test program begins.

M x
(%] JPOSTest program [E=SEEET™)

[ POSPrinter | CashDrawer |
Logical name: ,SRF’<350pIusII| | JPOS_S_CLOSED
| Open ’ | Claim | I Release | | Close | ‘ Info | \ Statistics ’ | OICIE I | EXIT I
[[] Device enabled  Station: ® Receipt () Journal O Slip [No Rotation [+] Map Mode:
[_] Freeze events 1 General Printing [ Barcode IlBitmap I Page Mode [ Additional Method r Property |
[] Asynchronus Mode Send to printer:
: JavaPOS String
|| [ ] Flag when idle
Begin Insertion
End Insertion e Print Normal
- Print Inmediate
Begin Removal Set Bottom Logo
Validate Data I
End Removal Cut Paper
Letter Quality
Add Escape Seq.
Device M g
-/
| — — - —

1) Logical Name: type the logical name saved by Jpos Entry Editor.
2) Click “Open” button to open JavaPOS device service.

3) Click “Claim” button to check the status of device.

4) Check “Device enabled” check box.

5) You can test each function with each button.
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4. Sample Source
The content of the “Sample Source” folder is as follows.

- sampleimage.bmp: sample image
- * java: java source file

4-1 POS Printer Samples

1) PrintNormalSample. java PrintNormal function sample source

2) PrintBitmapSample. java PrintBitmap function sample source

3) PrintBarcodeSample. java PrintBarcode function sample source

4) CutPaperSample. java CutPaper function sample source

5) ESCSequenceSample. java ESC Sequence sample source

6) CheckHealthSample. java CheckHealth function sample source

7) POSPrinterEventSampe. java POSPrinter-related event sample source

4-2 CashDrawer Samples
1) OpenCashdrawerSample. java Opendrawer function sample source

2) CashdrawerEventsSample. java Cashdrawer-related event sample source
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5. Precautions

- The BIXOLON JavaPOS software package that is installed supports devices offered by
BIXOLON. Normal operation is not guaranteed when used with other devices.

- Errors in operation may occur if installed with another JavaPOS Driver.

% If an unknown issue occurs, either contact the dealer or submit an inquiry at the
website below for fast response.

www.bixolon.com
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